PDA

View Full Version : Black Label Ads Issue



erikmanley79
12-01-2011, 09:53 AM
Has anyone found a solution that allows for the use of black label ads on a site powered by adult watch script? I tried wrapping the ads in literal tags and placing the code right in the template files and that seemed to work but randomly the pages generate fatal errors or are broken. I assume this is due to the different blocks of ad code that gets written to the page at any given time.

If anyone has successfully added black label ads to an adult watch site please post here with the steps you took to make it work. I would also be interested in knowing if anyone has found a good alternative to black label ads that provides rotating ads so that I dont have to rely on some fly by night affiliate program that only offers gifs and may not pay well. Thanks.

erikmanley79
12-01-2011, 10:15 AM
I think I may have found what is causing the issue with black label ads but if an admin/dev or forum member that knows php could confirm that would be awesome. I think the brackets in the portion of ad code below is screwing with the smarty template code. I was reading that it might be needed to use {ldelim}{rdelim} tags in place of the {} in the ad code to escape the characters (i hope i said that correctly). I wish I could test this now to let you all know if it works but im stuck at work for another 7 hours lol. If anyone has any thoughts let me know.

the example i found looked like this:

<script language="JavaScript">
function foo() {ldelim}
... code ...
{rdelim}
</script>

which would generate this:

<script language="JavaScript">
function foo() {
.... code ...
}
</script>



portion of the ad code that might need these special tags.

try{var AdBrite_Iframe=window.top!=window.self?2:1;var AdBrite_Referrer=document.referrer==''?document.lo cation:document.referrer;AdBrite_Referrer=encodeUR IComponent(AdBrite_Referrer);}catch(e){var AdBrite_Iframe='';var AdBrite_Referrer='';}

erikmanley79
12-01-2011, 01:10 PM
so i was able to sneak a test and it looks like when i wrap every { or } char in the ad code with either {ldelim} or {rdelim} it works. I will load up the site tonight and try to break it by using the site normally and see what happens. hopefully if it works i can add the modified ad code to the admin area instead of directly to the templates.

Admin
12-01-2011, 04:31 PM
Ensure you wrapped your code in literal tags.

erikmanley79
14-01-2011, 02:39 AM
the ads are working nicely now. I had to add them directly in the template files but its a fair trade off.

mustang
20-04-2011, 02:44 PM
A better way that I use on my site is to use an iframe, Just create a new empty file name it black.php (or what ever) then ad your BL ad code to that file, and add the code in quotes below to the standard ads in your AW admin panel. Changing myadultsite with your info:)


<iframe border=0 frameborder=0 marginheight=0 marginwidth=0 width=160 height=600 scrolling=no allowtransparency=true src=http://myadultsite.com/black.php></iframe>